Resolved
This issue is now resolved
Monitoring
We have deployed a fix and we're waiting for the queue to catch up
Identified
We're seeing a delay in delivery of events to external third party services.
The problem is identified and we're deploying a fix