Resolved
This issue is now resolved
Monitoring
We have identified the root cause and are now processing the backlog of delayed tasks. Services are returning to normal.
Investigating
We're experiencing some slow down in delivery of events to external services.
Our team have investigate and working on deploying a fix